Device platforms compatible with GO!Enterprise Workspace
Posted by Foivos Pappas on 07 October 2014 12:04 PM

GO!Enterprise Workspace is accessible through any type of mobile devices operating:

  • Android (handsets & tablets)(version 2.2 or later)
  • iOS (iPhone & iPad) (version 5.1 or later)
  • Blackberry 10
  • Windows Phone verson 8
  • Windows 8/8.1

The apps for Windows Phone 7.5 and BlackBerry 6/7 are no longer recommended for use because they lack current functionality. They will soon reach end-of-life status and will be removed from the marketplace.