Knowledgebase: Android with TouchDown
Upgrading to TouchDown version 6.1.0007 on a device running Android OS 1.5 requires an uninstall of the old TD version
Posted by Donna Magada on 30 July 2010 04:46 PM

If you are upgrading your TouchDown software from version 5.1.0026 or less and are running Android operating system v1.5, you must uninstall your TouchDown software before downloading and installing the current version. 

If your device runs Android OS 1.6 or 2.x, you do not have to uninstall TouchDown before downloading and installing the current version.