Windows Mobile ActiveSync devices fail to complete registration
Posted by Heather Burkett on 12 March 2010 02:06 PM

Issue:

Windows Mobile devices connecting to the NotifyLink server via ActiveSync are not registering successfully.  However, all other ActiveSync connected devices, such as iPhones, Android using TouchDown, and WebOS devices are registering without issue.

Cause:

Windows Mobile devices using ActiveSync may not be able to register with NotifyLink Enterprise Server if Integrated Windows authention is enabled on the 'Sync' virtual directory.  This is primarily seen on devices that have the 6.5 operating system.   
Note that even when 'anonymous access' is enabled, the Integrated Windows authentication option may still be selected.  Other ActiveSync devices do not have a problem as long as 'anonymous access' is enabled, so other devices may be connecting successfully.

Solution: 

Use the IIS Manager on the server running the NotifyLink HTTP/Web Component to check the authentication settings on the 'Sync' virtual directory.

-Go into IIS Manager and expand the web site that NotifyLink is using. Right click on the Sync directory and select Properties.

-Select the Directory Security tab, then under Authentication and Access Control, select Edit.  

-Ensure that the Enable Annonymous Access check box is selected and also verify that Integrated Windows Authentication is de-selected. 

 

Windows Mobile ActiveSync devices should then register successfully to the NotifyLink server.