NotifySync Device Client:
Problem
NotifySync hangs during the registration process when registering to a Zimbra server. After the registration screen is dismissed, NotifySync hangs in the message list screen but never completes the initial synchronization with the server and never downloads any items.
Cause
This problem is caused by a bug in the Zimbra server related to the folder structure in the ActiveSync server account. The Zimbra server attempts to synchronize a folder structure to the device that contains one or more folders identified as a sub-folder of another folder. The folder that is identified as the parent folder, however, does not exist anywhere in the folder structure.
Solution
The solution to this problem is to remove the erroneous folder from the server-side Zimbra account and then re-register NotifySync to the Zimbra server. Sometimes the erroneous folder is not visible on the server-side account, so it may be necessary for Notify technical support and/or Zimbra technical support to assist in identifying and fixing the problematic folder. As an extreme measure, removing and re-creating the account on the Zimbra server should also solve the problem.