10 Sep 2010
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Calendar synchronization (server to device) fails to add, update, or delete items properly.
Calendar synchronization (server to device) fails to add, update, or delete items properly.
Article
NotifySync:
Behavior
Calendar items originating on the server are not added to the calendar on the device after synchronization.
Calendar items updated on the server cause duplication of the corresponding item in the calendar on the device after synchronization.
Calendar items deleted on the server are not deleted from the calendar on the device after synchronization.
Possible Cause and Solution
Cause:
Your BlackBerry calendar has been corrupted by a yearly recurring event that occurs during the month of January. There is a bug in the BlackBerry device operating system software in which the BlackBerry calendar becomes corrupt when such an event has been saved. Once this corruption occurs, NotifySync is unable to synchronize items with the BlackBerry calendar until the calendar has been repaired.
Solution:
Make sure that the newest version of NotifySync is installed. The latest versions of NotifySync will convert all yearly recurring events (that originate on the server) to monthly recurring events that occur every 12 months. This does not alter the recurrences of the event and therefore the occurrences will appear exactly the same in the BlackBerry calendar.
Prevention:
When creating events on the device, avoid creating yearly recurring events. Instead, create monthly recurring events that occur every 12 months to get the same results.
Repairing the BlackBerry Calendar
To repair the BlackBerry calendar you can use the advanced Backup/Restore feature in the BlackBerry Desktop Manager to clear all of the records in the “Calendar” database. It is recommended that you disable Calendar synchronization in NotifySync before attempting to repair the BlackBerry Calendar using this method. You can re-enable Calendar synchronization afterward and your calendar items will be reloaded to the BlackBerry calendar from your ActiveSync server account.
You can also erase all of the application data on the device using the Application Loader in the BlackBerry Desktop Manager or from the device by going to Options -> Security Options -> General Settings and selecting “Wipe Handheld” from the menu. You do not have to select “Include third party applications” when performing this from the device. This method will erase application data from all of the applications on your device. You will need to re-register your NotifySync account and resynchronize with your ActiveSync server account.
Article Details
Article ID:
413
Created On:
30 Jun 2009 4:39 PM
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